Помогите написать программу на паскале АВС. светофор переключается каждые 10 секунд. В 0 часов 0 минут 0 секунд горит зелёный. какой цвет будет гореть через 4 часа 5 минут 23 секунды
var
timeInSec:integer; // время в секундах
color, s, m, h:byte;
begin
h := 4; //часы
m := 5; //минуты
s := 23; //секунды
timeInSec := h * 3600 + m * 60 + s; //перевод времени в секунды
color := (timeInSec div 10) mod 3; {целочисленно делим на 10, чтобы узнать сколько раз светофор изменил цвет}
{потом находим остаток деления на 3(количество цветов), чтобы узнать какой сейчас цвет}
case color of //вывод ответа
0: writeln(Горит зеленый свет); //0 - это зеленый свет
1: writeln(Горит желтый свет); //1 - это желтый свет
2: writeln(Горит красный свет); //2 - это крсный свет
end;
end.
Оцени ответ
