Дано натуральное число. Установить является ли последовательность его цифр при просмотре их слева направо упорядоченной по неубыванию. Например, для чисел 5321 и 9663 ответ положительный , для чисел 7820 и 9663 отрицательный и т.п.
Написать программу на паскале, не используя массивы, boolean
Var s: string;
begin
write(число: ); readln(s);
if s=s.Sorted.Reverse.JoinIntoString() then
writeln(упорядочено по неубыванию)
else writeln(НЕ упорядочено);
end.
Оцени ответ
