для заданного одномерного массива с компонентами вещественного типа написать программу решения задачи:

вычислить разность между наибольшим и наименьшим элементом.

program fnued;

uses crt;

var a:=array [1..1000] of integer;

      i,n,max,min,r:real;

begin

clrscr;

readln(n);

for i:=1 to n do

readln(a[i]);

min:=a[1];

max:=a[1];

for i:=1 to n do

if a[i]>max then max:=a[i];

for i:=1 to n do

if a[i]

r:=max-min;

writeln(r);

readln;

end.

 

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку