Составьте программу проверки эквивалентности двух логических функций. Постройте соответствующие таблицы истинности(программно).
1.Проверьте что X → Y эквивалентна not (x) or y

//так и не осознала как вводить функции с клавиатуры. Спрошу у учителя.
var b1,b2,b:boolean;

function imp(a, b : boolean) : boolean;
begin
imp:=(not a) or b;
end;

begin;
writeln(Implication);
For b1:=false to true do
For b2:=false to true do
writeln(b1:7,b2:7,imp(b1,b2):7);

writeln(not (x) or y);
For b1:=false to true do
For b2:=false to true do
writeln(b1:7,b2:7,((not b1) or b2):7);

For b1:=false to true do
For b2:=false to true do
if imp(b1,b2)<>((not b1) or b2) then
 begin;
  writeln(Не эквивалентны);
  exit;
 end;
writeln(Эквивалентны);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку