Написать программу, которая вводит десять чисел в одномерный массив, а затем определяет среднее арифмитичне элементов с четными индексами и нечетными индексами

Var r,n,m,max,k,el,Sumh,Sumnh:integer;C:Array[0..9]of integer;Sh,Snh:real; 
Begin
for r:=0 to 9 do begin
C[r]:= random(50)-25;  write(C[r]:4);
if r mod 2 = 0 then Sumh := Sumh + C[r]
else Sumnh:= Sumnh + C[r];end;
Sh:= Sumh/5;Snh:= Sumnh/5;writeln;
writeln(среднеарифметическое элемент с четными индексами ,Sh:6:4);
write(среднеарифметическое элемент с четными индексами ,Snh:6:4);end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку