Напишите программу, которая содержит тест (Pascal)
Уровень самооценки тест
Отвечая на вопросы, указывайте, как часты для Вас перечисленные ниже состояния по такой шкале:
очень часто – 4 балла;
часто – 3 балла;
иногда – 2 балла;
редко – 1 балл;
никогда – 0 баллов.
1. Я часто волнуюсь понапрасну.
2. Мне хочется, чтобы мои друзья подбадривали меня.
3. Я боюсь выглядеть глупцом.
4. Я беспокоюсь за свое будущее.
5. Внешний вид других куда лучше, чем мой.
6. Как жаль, что многие не понимают меня.
7. Чувствую, что я не умею как следует разговаривать с людьми.
8. Люди ждут от меня очень многого.
9. Чувствую себя скованным.
10. Мне кажется, что со мной должна случиться какая-то неприятность.
11. Меня волнует мысль о том, как люди относятся ко мне.
12. Я чувствую, что люди говорят про меня за моей спиной.
13. Я чувствую себя в безопасности.
14. Мне не с кем поделиться своими мыслями.
15. Люди не особенно интересуются моими достижениями.
Чтобы определить уровень своей самооценки, нужно сложить все баллы по утверждениям. А теперь посчитайте, сколько получится в сумме.
Если меньше 10, вам надо избавляться от чувства превосходства над окружающими, зазнайства, хвастовства. Возьмите за правило принципы: всякая конфликтная ситуация возникла из искры, которую вы высекли сами или помогли разжечь.
Если сумма превышает 30, то вы себя недооцениваете.
Набранное количество баллов от 10 до 30 свидетельствует о психологической зрелости, которая проявляется прежде всего в адекватности самоотражения, то есть реалистической оценке своих сил, возможностей, внешности. Вам по плечу серьезные дела. Дерзайте!

Var s:string;
k:integer;

procedure res(s:string;var k:integer);
begin;
if s=очень часто then k:=k+4;
if s=часто then k:=k+3;
if s=иногда then k:=k+2;
if s=редко then k:=k+1;
end;

begin;
writeln(1. Я часто волнуюсь понапрасну.);
readln(s);
res(s,k);
writeln(2. Мне хочется, чтобы мои друзья подбадривали меня.);
readln(s);
res(s,k);
writeln(3. Я боюсь выглядеть глупцом.);
readln(s);
res(s,k);
writeln(4. Я беспокоюсь за свое будущее.);
readln(s);
res(s,k);
writeln(5. Внешний вид других куда лучше, чем мой.);
readln(s);
res(s,k);
writeln(6. Как жаль, что многие не понимают меня.);
readln(s);
res(s,k);
writeln(7. Чувствую, что я не умею как следует разговаривать с людьми.);
readln(s);
res(s,k);
writeln(8. Люди ждут от меня очень многого.);
readln(s);
res(s,k);
writeln(9. Чувствую себя скованным.);
readln(s);
res(s,k);
writeln(9. Чувствую себя скованным.);
readln(s);
res(s,k);
writeln(10. Мне кажется, что со мной должна случиться какая-то неприятность.);
readln(s);
res(s,k);
writeln(11. Меня волнует мысль о том, как люди относятся ко мне.);
readln(s);
res(s,k);
writeln(12. Я чувствую, что люди говорят про меня за моей спиной.);
readln(s);
res(s,k);
writeln(13. Я чувствую себя в безопасности.);
readln(s);
res(s,k);
writeln(14. Мне не с кем поделиться своими мыслями.);
readln(s);
res(s,k);
writeln(15. Люди не особенно интересуются моими достижениями.);
readln(s);
res(s,k);
if k<10 then
writeln(Вам надо избавляться от чувства превосходства над окружающими, зазнайства, хвастовства. Возьмите за правило принципы: всякая конфликтная ситуация возникла из искры, которую вы высекли сами или помогли разжечь.);
if k>30 then
writeln(Вы себя недооцениваете);
if (k>=10) and (k<=30) then
writeln(Набранное количество баллов от 10 до 30 свидетельствует о психологической зрелости, которая проявляется прежде всего в адекватности самоотражения, то есть реалистической оценке своих сил, возможностей, внешности. Вам по плечу серьезные дела. Дерзайте!);end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку