Написать программу для вычисления N-ой степени числа a (aN). Протестировать программу для а) a=3 и N=4, б) a=2 и N=5.

Program zadacha;

var a,n,i:integer;

Begin

read(a,n);

for i:=1 to n do

      a:=a*a;

writeln(a);

end.

 

или как вариант

 

Program zadacha;

var a,n:integer;

Begin

read(a,n);

x:=exp(ln(a)*n);

writeln(x);

end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку