Помогите составить программу в Pascal!
Задана последовательность слов. Определить частоту вхождения каждого из слов в последовательность.
Var s,r,k: string;
j: integer;
begin
write(строка: ); readln(s);
foreach k in s.Split( ).Distinct do
begin
j:=0;
foreach r in s.Split( ) do
if r=k then j:=j+1;
writeln(слово ,",k,", встречается ,j, раз);
end;
end.
Оцени ответ
