Дана последовательность действительных чисел а1, а2,...,an. Заменить все её члены, больше данного Z, этим числом. Подсчитать количество замен. Помогите,пожалуйста,написать программу. Я запуталась что-то.
Var ar:array of integer;
z,i,n,o:integer;
begin;
o:=0;
readln(n);
readln(z);
setlength(ar,n+1);
for i:=1 to n do
begin;
readln(ar[i]);
if ar[i]>z then
begin;
inc(o);
ar[i]:=z;
end;
end;
writeln(Array:);
for i:=1 to n do
write(ar[i]:4);
writeln;
writeln(Количество замен=,o);
end.
Оцени ответ
