В зависимости от введённого символа L, S, V программа должна вычислять длину окружности; площадь круга; объём цилиндра по заданному радиусу R.
Составить программу на паскале.

Var
L, S, V, Symbol: String;
P, So, Vc: Real;
R, H: Integer;
begin 
WriteLn(Введите R); ReadLn(R);
WriteLn(Введите H); ReadLn(H); 
L:= L;  //
S:= S; //
V:= V; // можно конечно обойтись и без них

WriteLn(Введите символ); ReadLn(Symbol);
 if Symbol = L then begin 
P:= 2*pi*R; 
WriteLn(Длина окружности = ,P);
end;
 if Symbol = S then begin 
So:= pi * sqr(R); 
WriteLn(Площадь круга = ,So); 
end;
 if Symbol = V then begin 
Vc:= pi * sqr(R) * H; 
WriteLn(Объем цилиндра = ,Vc);
end;
ReadLn;
end;

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку