Ниже записан алгоритм. Получив на вход число х, этот алгоритм печатает два числа L и M. Укажите наибольшее из таких чисел х, при вводе которых алгоритм печатает сначала 3, а потом 120.

var х, L, M: integer;
begin
readln (x) ;
L: = 0 ; M : = 1;
while x>0 do
begin
L : = L + 1 ;
M : = M*(x mod 8) ;
х : = x div 8;
end ;
writeln(L); write(M);
end.

Ответ: 428

нашел с помощь программы

 

var
  x, L, M, i:integer;
begin
  for i := 4096 downto 1 do
  begin
    L := 0;
    M := 1;
    x := i;
    
    while x > 0 do
    begin
      Inc(L);
      M := M *(x mod 8);
      x := x div 8;
    end;

    if (L = 3) and (M = 120) then
    begin
      WriteLn(x = , i);
      break;
    end;
  end;
  readln;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку