Помогите пожалуйста. программа Паскаль дано трехзначное число. Напишите программу, которая определяет: является ли число перевертышем, т.е числом, десятичная запись которого читается одинаково слева направо и справа налево Пример входных данных: 122, 121, 222 Пример выходных данных: нет, перевертыш, перевертыш

var
  c, f, First, count:integer;
begin
  write(c = );
  readln(c);
  f := c;
  while (f div 10 > 0) do
  begin
    First := f div 10;
    count := 1;
    while (First div 10 > 0) do
    begin
      First := First div 10;
      Inc(count);
    end;
    if First <> f mod 10 then
    begin
      writeln(No);
      readln;
      Exit;
    end;
    
    while count > 0 do
    begin
      First := First * 10;
      dec(count);
    end;
    f := f - First;
    f := f div 10;
  end;
  writeln(Changeling);
  readln;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку