Составьте программу вычисления суммы нечетных цифр натурального числа М(ПАСКАЛЬ АБЦ)
Var x,y:integer;
begin
read(x);//число
while(x <>0) do begin
if x mod 10 mod 2=1 then y:=y+x mod 10;
x:=x div 10;
end;
writeln(y);
end.
Оцени ответ
Вход
Регистрация
Задать вопрос
Var x,y:integer;
begin
read(x);//число
while(x <>0) do begin
if x mod 10 mod 2=1 then y:=y+x mod 10;
x:=x div 10;
end;
writeln(y);
end.