Требуется поменять местами первый элемент массива с максимальным.ВХОДНЫЕ ДАННЫЕ
В первой строке вводится одно натуральное число, не превосходящее 1000 — размер массива. Во второй строке задаются N чисел — элементы массива (целые числа, не превосходящие по модулю 1000).
ВЫХОДНЫЕ ДАННЫЕ
Вывести получившийся массив. Если максимальных элементов несколько, требуется поменять первый из них.
ПРИМЕРЫ
ВВОД ВЫВОД
5
1 2 3 4 5
5 2 3 4 1

Var a:array[1..1000] of integer;
i,n,max,m:integer;
begin
write(n=);readln(n);
for i:=1 to n do read(a[i]);
max:=a[1];m:=1;
for i:=2 to n do if a[i]>max then
 begin max:=a[i]; m:=i; end;
a[m]:=a[1];a[1]:=max;
for i:=1 to n do write(a[i],  );
writeln;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку