Дан одномерный массив целых чисел, состоящий из 20 ячеек, заполненный случайными числами из промежутка [-100,90]. Увеличить каждый элемент массива на 100. Напишите программу со всеми объяснениями пожалуйста!!

Написал две программки на случай, если там все таки массив  определен:
1)
var
a:array[1..20]of integer;
i,n,c:integer;
begin
 for i:=1 to 20 do
  begin
   read(a[i]);
   a[i]:=a[i]+100;
  end;
  for i:=1 to 20 do
  write(a[i], );
  end.


2)
var
a:array[1..20]of integer;
i,n,c:integer;
begin
  for i:=1 to 20 do
  begin
   a[i]:=random(191)-100;
   write(a[i], );
  end;
  writeln;
  for i:=1 to 20 do
  write(a[i]+100, );
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку