Моделирование однострочного редактора.
Паскаль АВС
На вход программе подается строка и команда удаления DEL i n, где i – номер символа в строке, начиная с которого надо удалить n символов. Требуется удалить из данной строки n символов, начиная с i-го. Например, для строки my old name was Thom команда DEL 4 3 приведет к удалению слова old: my name was Thom.
// PascalABC.NET 3.0, сборка 1111
begin
var s:=ReadLnString(Введите строку: );
var a:=ReadLnString(Введите команду: ).ToWords;
Delete(s,StrToInt(a[1]),StrToInt(a[2]));
Writeln(Результат: +s)
end.
Тестовое решение:
Введите строку: my old name was Thom
Введите команду: DEL 4 3
Результат: my name was Thom
Оцени ответ
