составьте программу дискриминанта так, чтобы а,b,с -задавались генератором случайных чисел (random);+эта программа должна включать в себя !двухмерный массив размером 5 на 10 ( в Pascal )
var
a: array [1..5,1..10] of integer;
i,j:integer;
begin
for i:=1 to 3 do
begin
for j:=1 to 10 do
a[i,j]:=random(50)-100;
end;
for j:=1 to 10 do
a[4,j]:=sqr(a[2,j])-4*a[1,j]*a[3,j];
for j:=1 to 10 do
writeln(a=,a[1,j], b=,a[2,j], c=,a[3,j], D=,a[4,j]);
readln;
end.
p.s не понял зачем там массив 5х10 если нужно найти дискриминант?
Оцени ответ
