Как на Pascal ABC написать программу, которая будет считать сумму цифр в числе, введенного с клавиатуры?
Количество цифр в числе не известно! Число целочисленное! Желательно с объяснениями ( вне программы ). Заранее спасибо!!!

Var a,b,c,d:integer;
begin
writeln(введите число); //запрос числа
readln(a);
d:=a;                 //это для красоты
while (a<>0) do begin //пока мы не дойдём до последней цифры в числе делать следующее
  b:=a mod 10;        //берём последнюю цифру числа 
  c:=c+b;             //находим сумму цифр
  a:=a div 10;        //убираем из данного числа последнюю цифру
  end;
 writeln(сумма цифр числа ,d, = ,c); // вывод результата
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку