Как на Pascal ABC написать программу, которая будет считать сумму цифр числа, введенного с клавиатуры?
Количество цифр в числе неизвестно! Число целое. Очень желательно с объяснениями (вне программы). Заранее спасибо!!!
P.S. Я дам 15 баллов! Очень нужно!!!

Program LOL2016;
var n,s,r:integer;
begin
readln(n);
s:=0;
while(n <> 0) do begin
r:=n mod 10;
s:=s+r;
n:=n div 10;
end;
writeln(s);
end.

если что то не понятно просто спроси и я обьясню  :)

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку