напишите программу вычисления наибольшего общего делителя двух целых чисел. а)с оператором repeat б) с оператором while ( в интернете неправильно)помогите пожалуйста

var a,b: integer;

begin

   readln(a,b);

   repeat

      if(a>b) then a:=a-b;

      if(b>a) then b:=b-a;

   until (a<>b); 

   writeln(gcd = , a);

end.

 

var a,b: integer;

begin

   readln(a,b);

   while (a<>b) do begin

      if(a>b) then a:=a-b;

      if(b>a) then b:=b-a;

   end;

   writeln(gcd = , a);

end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку