Паскаль.1)Определите, сколько чисел, введённых пользователем делятся на 3 без остатка. Ввод чисел пользователем заканчивается после ввода цифры 0. 2)Найдите сумму цифр числа, меньших 5. Например, для числа 715245 это будет 1+2+4=7. Написать блок-схему и программу.

1)

program ABC;

var num,count:integer;

 

begin

readln(num);

while num<>0  do

begin

    if (num mod 3) = 3 then

          count:=count+1

end;

writeln(count)

end.

 

2)

program ABC;

var num,sum:integer;

 

begin

readln(num);

while num<>0  do

begin

    if (num mod 10) < 5 then

          sum:=sum+num mod 10;

    num:= num div 10

end;

writeln(sum)

end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку