Найдите наименьшее к такое, что к факториал делится на n без остатка

Var k,n,f:integer;
begin
write(n=);readln(n);
k:=1;f:=1;
while f mod n <> 0 do
 begin k:=k+1; f:=f*k; end;
writeln(k=,k);
end.

Пример:
n=30
k=5

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку