Программа получает на вход набор точек на плоскости. Сначала задано количество точек n, затем идет последовательность из n строк, каждая из которых содержит два числа: координаты точки. Величина n не превосходит 100, все исходные координаты – целые числа, не превосходящие 103. Выходные данные Выведите координаты центра тяжести данного множества точек. Ответ необходимо выводить с точностью в 15 значащих цифр.

displaystyle X_c=  frac{1}{n} sum_{i=1}^n}{x_i} ;  Y_c=  frac{1}{n} sum_{i=1}^n}{y_i}

// PascalABC.NET 3.0, сборка 1128
var
  n,i:integer;
  x,y,xc,yc:double;
begin
  Write(n=); Read(n);
  xc:=0; yc:=0;
  for i:=1 to n do begin
    Read(x,y);
    xc:=xc+x; yc:=yc+y
    end;
  Writeln(Xc=,xc/n,, Yc=,yc/n)
end.

Тестовое решение:
n=5
1.16 -3.7
9.35 0
5.173 2.2432
-4.1 6.77
-5 5
Xc=1.3166, Yc=2.06264

Замечание: если результаты будут иметь большее количество цифр, то в пределах 15 все эти цифры будут показаны.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку