Дан целочисленный массив из 20 элементов. Элементы массива могут быть
целыми числами от -1000 до 1000. Найдите минимальный элемент среди
положительных, делящихся на 3 и нечетных

Uses crt;
const n=20;
var i,min:integer;
a:array [1..n]   of integer;
begin
randomize;
for i:=1 to n do
 a[i]:= random(2001)-1000; {read (a[i])}{ручной ввод чисел}
min:=1001;
for i:=1 to n   do
if (a[i]>0)  and (a[i]mod 3=0) and (odd(a[i])) and (a[i] min:=a[i];
if min<>1001 then
 writeln(min)
else
  writeln(нет чисел удовлетворяющих заданному условию);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку