59 БАЛЛОВ ЗА ПОЛНОЕ РЕШЕНИЕ! Нужно составить программу на PascalABC.NET и сделать все как на скришоте ниже.
// PascalABC.NET 3.0, сборка 1139 от 10.01.2016
program massiv;
const
n=5;
type
V=array[1..n] of real;
procedure vvod_vand(var A:V; n:integer);
begin
Randomize;
for var i:=1 to n do A[i]:=20*Random
end;
procedure vvod(var B:V; n:integer);
begin
Writeln(Введите элементы массива);
for var i:=1 to n do Read(B[i])
end;
function sred(var D:V):real;
begin
Result:=D.Average;
end;
var
a:V;
begin
var f:=OpenWrite(myfile.txt);
vvod(a,n);
Writeln(f,Введенные элементы массива);
foreach var c in a do Write(f,c, ); Writeln(f);
Writeln(Среднее: ,sred(a));
Writeln(f,Среднее: ,sred(a));
Writeln(Случайные числа);
Writeln(f,Случайные числа);
vvod_vand(a,n); a.Println(, );
foreach var c in a do Write(f,c, ); Writeln(f);
Writeln(Среднее: ,sred(a));
Writeln(f,Среднее: ,sred(a));
f.Close
end.
Тестовое решение:
Введите элементы массива
3 5.2 -3.7 6 -1.112
Среднее: 1.8776
Случайные числа
11.5666489450106, 6.30297457161498, 6.51701744949306, 10.1566330204516, 18.8177900010803
Среднее: 10.6722127975301
