Составьте программу нахождения наименьшего общего кратного (НОК) двух чисел, используя формулу: А*В = НОД(А*В)*НОК(А, В). (по алгоритму Евклида на Паскале)
// PascalABC.NET 3.0, сборка 1139 от 10.01.2016
function NOD(a,b:integer):integer;
begin
while a <> b do
if a > b then a:=a-b
else b:=b-a;
NOD:=a
end;
begin
var a:=ReadInteger(A=);
var b:=ReadInteger(B=);
Writeln(HOK=,(a*b) div NOD(a,b))
end.
Тестовое решение:
A= 18
B= 42
HOK=126
Оцени ответ
