"ГНЧЭ-1" – сложное электронное устройство, выдающее каждую секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду дороговизны электронных комплектующих вам поручено разработать эмулятор для этого устройства.
Формат входного файла
Дано количество секунд (от 1 до 1000000), которые работает генератор после включения.
Формат выходного файла
Результат работы генератора
Имхо так:
Program solution;
Uses Crt;
Var sec, num, n1, i : Longint;
Begin
ClrScr;
Readln(sec);
num := 1;
n1 := 0;
repeat
for i := 1 to num do
begin
write(num, );
n1 := n1 + 1;
if n1 >= sec then break;
end;
num := num + 1;
until n1 >= sec;
End.
Оцени ответ
