ПРОШУ ПОМОГИТЕ ОЧЕНЬ СРОЧНО
Найдите самый маленький натуральный делитель числа x, отличный от 1 (2 <= x <= 30000).
Входные данные
Вводится натуральное число x.
Выходные данные
Выведите наименьший делитель числа x, отличный от 1.
Примеры
входные данные
2
выходные данные

Var x:integer;
begin
   readln(x);
    for var i:=2 to x do
      if (x mod i)=0 then begin
        writeln(delitel: ,i);
        exit;
      end;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку