Помогите пожалуйста!!!
Найдите самый маленький натуральный делитель числа х, отличный от 1 (2<=х<=30000).
Входные данные
выходится натуральное число
выходные данные
выведите наименьший делитель числа х, отличный от 1
Примеры
входные данные
2
выходные данные
2
Var x:integer;
begin
readln(x);
for var i:=2 to x do
if (x mod i)=0 then begin
writeln(delitel: ,i);
exit;
end;
end.
Оцени ответ
