Сформируйте массив, содержащий 15 элементов, с помощью датчика случайных чисел. Получите новый массив, каждый элемент которого равен удвоенному соответствующему элементу исходного массива . В полученном массиве найдите максимальный элемент среди элементов, номера которых кратны трем. Выведите на экран исходные и полученные результаты.

const  N=15

var a: array |1...N| of integer;

i,m,n :integer;

begin 

for i:=1 to N do readln (a|i|);

m:=0

for i:=1 to N do begin

a|i|:=a|i|*2;

end;

for i:=1 to N do 

if (i mod 3=0) and ((a|i|>m)or (m=0)) then

m:=a|i|;

writeln (m);

end.

 

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку