Напишите программу, которая в последовательности натуральных чисел определяет количество трёхзначных чисел, кратных 4. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).
Количество чисел не превышает 1000. Введённые числа не превышают 30 000.
Программа должна вывести одно число: количество трёхзначных чисел, кратных 4.
Напишите программу в паскале пожайлуста.

Var x,k:integer; 
begin 
k:=0; 
writeln(Введите числа); 
repeat 
read(x); 
if (x mod 4=0) and (x>=100) and (x<=999) then k:=k+1; 
until x=0; 
writeln(Количество трехзначных чисел кратных 4 = , k); 
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку