Написать программу: Дано 5 произвольных натуральных чисел. Найти среднее арифметическое отрицательных кратных пяти.
Program z1;
var
mas: array[1..10] of integer;
i,s,sr,k: integer;
begin
s:=0;
k:=0;
writeln(Введите 5 чисел);
for i:=1 to 5 do
begin
readln(mas[i]);
if (mas[i]<0) and (mas[i] mod 5=0) then
begin
s:=s+mas[i];
k:=k+1;
end;
end;
sr:=s div k;
writeln(Среднее арифметическое чисел, кратных 5, равно ,sr);
end.
Оцени ответ
