Паскаль турбо
Написать программу, которая запрашивает у пользователя строку символов и подсчитывает, сколько раз в этой строке встречается последовательность символов «abc».
Написать программу, которая запрашивает у пользователя две строки символов и определяет, которая из них длиннее.
написать программу, которая запрашивает две строки, копирует первые два символа каждой строки, а затем склеивает скопированные в новую строку.

1.
var
  s: string;
  i, count: integer;
begin
  writeln(Vvedite stroky: );
  readln(s);
  for i := 1 to length(s) - 2 do
    if copy(s, i, 3) = abc then
      count := count + 1;
  writeln(Kol-vo: , count);
end.
2.
var
  s1, s2: string;
  i, len1, len2: integer;
begin
  writeln(Vvedite stroky 1: );
  readln(s1);
  writeln(Vvedite stroky 2: );
  readln(s2);
  len1 := length(s1);
  len2 := length(s2);
  if len1 > len2 then writeln(1 stroka dlinnee)
  else if len1 < len2 then writeln(2 stroka dlinnee)
  else writeln(dlini strok ravnie)
end.
3.
var
  s1, s2, s3: string;
begin
  writeln(Vvedite stroky 1: );
  readln(s1);
  writeln(Vvedite stroky 2: );
  readln(s2);
  s3 := s1[1] + s1[2] + s2[1] + s2[2];
  writeln(Novaja stroka: , s3);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку