Составить программу в паскаль. С клавиатуры вводится произвольная последовательность положительных чисел, за которой следует 0. Определить: 1.Максимальное число в этой последовательности. 2.Количество четных чисел.

//Pascal ABC.NET v3.0 сборка 1111
var
 a,k,max:integer;
begin
a:=1;
max:=-1000;
k:=0;
 while a<>0 do
  begin;
   if not(odd(a)) then inc(k);
   if max   readln(a);
  end;
writeln(Max=,max,, not odd:,k);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку