Для каждой задачи составить программу , содержащую ветвления и определяющую , принадлежит ли точка с координатами (х;y) заштрихованной области. Помогите пожалуйста очень надо

Var x, y: real;
begin
  read(x, y);
  if (x >= -4) and (x <= -1) then
    if (y >= 1) and (y <= 7) then
      writeln(Yes)
    else
      writeln(No)
  else if (x >= -1) and (x <= 3) then
    if (y >= 4) and (y <= 7) then
      writeln(Yes)
    else
      writeln(No)
  else
    writeln(No)
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку