Напишите программу, которая случайным образом выбирает дежурных: выводит два случайных числа в диапазоне от 1 до N, где N- количество учеников вашего класса. С какой проблемой вы можете столкнуться?
Нужно сделать в Паскале. Заранее спасибо!
// PascalABC.NET 3.0, сборка 1150 от 22.01.2016
var
n,n1,n2:integer;
begin
Write(Количество учеников: ); Read(n);
Randomize;
n1:=Random(n)+1;
n2:=n1;
while n2=n1 do n2:=Random(n)+1;
Writeln(Номера дежурных: ,n1,, ,n2)
end.
Тестовое решение:
Количество учеников: 35
Номера дежурных: 2, 26
Оцени ответ
