Помогите,пожалуйста,написать программу в Паскале
очень срочно...
Дан двумерный массив размером 4*6,заполненный целыми числами с клавиатуры.Сформировать одномерный массив,каждый элемент которого равен кол-ву элементов соответствующей строки,больших данного числа.

Var
   x:real;
   arr2: array [1..4,1..6] of integer;
   arr1: array [1..4] of integer;
begin
      writeln(Введи число для сравнения);
      readln(x);
      for var i:=1 to 4 do 
      begin
            writeln(Вводим строку ,i);
            for var j:=1 to 6 do
            begin
                  writeln(Введи число , j);
                  readln(arr2[i,j]);
                  if arr2[i,j]>x then arr1[i]:=arr1[i]+1;
            end;
    end;
    writeln(Двумерный массив: , arr2, Количество чисел больше заданного: , arr1);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку