Написать программу, вычисляющую сумму и среднее арифметическое последовательности положительных чисел, которые вводятся с клавиатуры. вид экрана: Введите числа. Для завершения последовательности нажмите ноль. 45 23 15 0 введено чисел:3 сумма чисел:83 Среднее арифметическое:27.67 С ЦИКЛОМ While do пожалуйста напишите а не с Repeat untill
program z8;
uses crt;
var
i,k,n:byte;
s:integer;
sa:real;
begin
clrscr; i:=1;
writeln(Для завершения последовательности нажмите ноль);
while i>0 do begin
read(i);
write( ); {- нужен, чтобы числа нормально смотрелись}
if i>0 then begin
k:=k+1;
s:=s+i;
end; end;
sa:=s/k;
write(введено чисел:,k, сумма чисел:,s,Среднее арифметическое:,sa:4:2);
readkey
end.
Оцени ответ
