Напишите программу,
которая вычисляет среднюю за неделю температуру воздуха.
Исходные данные вводятся с клавиатуры.
Пример входных данных.
Понедельник>> 12
Вторник>>10
Среда>>16
Четверг>>18
Пятница>>17
Суббота>>16
Воскресенье>>14
Пример выходных данных
Средняя температура за неделю: 14.71

Class MiddleTemperature{
 public static void main(String args[]){
  java.util.Scanner in = new java.util.Scanner(System.in); double tSum = 0;
  for(int day = 0; day<7; day++){
   switch(day){
 case 0: System.out.print("Понедельник>>"); break;
 case 1: System.out.print("Вторник>>"); break;
 case 2: System.out.print("Среда>>"); break;
 case 3: System.out.print("Четверг>>"); break;
 case 4: System.out.print("Пятница>>"); break;
 case 5: System.out.print("Суббота>>"); break;
 case 6: System.out.print("Воскресенье>>"); break;
   }
   tSum+=in.nextInt();
  } tSum/=7;
  System.out.print("Средняя температура за неделю: "+(int)tSum/1+"."+(int)(tSum%1.0/0.1)+(int)((tSum-(int)(tSum/0.1)/10D)/0.01));
 }
}

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку