Задача:Вывести числа до N, которые делятся на сумму своих цифр.
написать программу на языке СИ
// Возможно, это работает
#include
int main()
{
int x,s,l,n;
scanf("%d", &n);
do{
s = 0;
for(x = 1; x <= n; x++)
{
s += 1;
l = 10;
while(x % l == 0){s -= 9; l *= 10;};
if(x % s == 0) printf("%d ",x);
};
printf("n");
scanf("%d", &n);
} while(n > 0);
}
Оцени ответ
