Нужно написать программу на PascalABC.
Вводится n чисел, найти максимальное двузначное среди них.
Var
n,max,i,a : longint;
begin
readln(n); {количество чисел}
max:=0; {чтобы вывести 0 если нет двухзначных}
for i:=1 to n do
begin
readln(a); {хранить массив не надо т.к. он нигде не требуется}
if (a>9) and (a<100) and (a>max)
then max:=a;
end;
if max>0
then writeln(max)
else writeln(нет двухзначных чисел)
end.
Оцени ответ
