Составьте программу в Паскаль. Седьмому классу на практике получено сдуть 1000 одуванчиков. Бригада мальчиков первый день сдуло А одуванчиков, а бригада девочек в два раза меньше. В каждый последующий день производительность мальчиков уменьшалась на 10 %,а девочек росла на 15 % по сравнению с предыдущим. Через сколько дней классы выполнит норму Вопросительный знак сколько сделают бригада мальчиков и девочек в отдельности?

Хорошая задачка! Хочется её решать в целых числах, но в условии этого не требуется.
var a,k:integer; m,d,sm,sd:real;
begin
write(A=); readln(a);
m:=a; d:=a/2;
sm:=m; sd:=d;
 k:=1;
while sm+sd<1000 do
 begin
 m:=m*0.9; sm:=sm+m;
 d:=d*1.15;sd:=sd+d;
 k:=k+1;
 end;
writeln(k=,k,  sm=,sm:6:2,  sd=,sd:6:2);
end.

Пример:
A=70
k=9  sm=428.81  sd=587.50

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку