напишите программу для паскаля.

условие: обменять значения двух переменных, используя третью(буферную) переменную

var

  a, b, buf:real;

begin

  write(a = ); readln(a);

  write(b = ); readln(b);

  buf := a;

  a := b;

  b := buf;

  writeln(a = , a);

  writeln(b = , b);

end.

 

 

// без буферной переменной

var

  a, b:real;

begin

  write(a = ); readln(a);

  write(b = ); readln(b);

  a := a + b;

  b := a - b;

  a := a - b;

  writeln(a = , a);

  writeln(b = , b);

end.

 

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку