Составить программу в Pascal.
3. Пусть дано 100 вещественных чисел, которые вводятся по одному. Вычисли¬те среднее арифметическое положительных и среднее арифметическое от¬рицательных чисел.
4. Напечатать таблицу соответствия между весом в фунтах и весом в кг для значений от 1 до 10 фунтов с шагом 0,5 фунта. Формула перевода: 1 фунт = 400 г.
5. Составьте таблицу значений функции y = 5x2 – 2x + 1 на отрезке [-5; 5] с шагом 2.

1)
   var
 a:array[1..100]of real;
 n,p,q,q1:real;
 i:integer;
   begin
    for i:=1 to 100 do
     begin
      read(a[i]);
      if a[i]>=0 then
       begin
        p:=p+a[i];
        q:=q+1;
       end;
      if a[i]<0 then
      begin
       n:=n+a[i];
       q1:=q1+1;
      end;
    end;
   writeln(positive:,p/q);
   writeln(negative:,n/q1);
 end.


2)
      uses crt;
var
n:real;
i:integer;
 begin
 n:=0.5;
 write(  Pounds,       Kg);
 writeln;
   for i:=1 to 20 do
    begin
    write (    ,n,       , n*0.4);
    n:=n+0.5;
    writeln;
    end;
  
 end.



3)
  uses crt;
var
x:integer;
 begin
  write( x,        y);
  writeln;
   for x:=-5 to 5 do
   begin
      write(x,       );
      write(5*(x*x)-(2*x)+1);
      writeln;
   end;
   end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку