Помогите пожалуйста в информатикой!
Напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех двузначных чисел, кратных 8. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0
(0 – признак окончания ввода, не входит в последовательность).
Количество чисел не превышает 1000. Введённые числа не превышают
30 000.
Программа должна вывести одно число: сумму всех двузначных чисел, кратных 8.

Program pr;
uses crt;

var
chislo, sum, i:integer;
Begin
sum:=0;
for i:=1 to 1000 do
   Begin
       Writeln(Введите число);
       readln(chislo);
       if (chislo=0) then break;

       if (chislo>30000) then Writeln(число превышает 30000)
           else
                Begin
                  if ((chislo>9) and (chislo<100) and (chislo mod 8 = 0))
                  then sum:=sum+chislo;
                end;
    end;

Writeln(sum = , sum);

readln;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку