Помогите пожалуйста срочно!!
Написать программу нахождения суммы всех чисел> заданного К при вводе до первого отрицательного.

//Pascal ABC.NET v3.0 сборка 1111

var
 a,k,s:integer;
begin
readln(k); //вводим k
a:=0;
s:=0;
 while a>=0 do //пока а >=0
  begin;
   if a>k then s:=s+a; //если a>k, тогда добавляем к s
   readln(a); //каждый раз вводим в a
  end;
writeln(s); //выводим s
end.

Пример ввода:
45
34
56
67
-2
Пример вывода:
123

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку