Как написать программу для pascal abc которая считает факториал числа который вводит пользователь
//Pascal ABC.NET v3.0 сборка 1111
//Обойдусь без .Net-овских примочек
var
a,b,i:integer;
begin
readln(a);
if a=0 then
begin;
writeln(1);
exit;
end;
if a<0 then
begin;
writeln(Не определён);
exit;
end;
b:=1;
for i:=1 to a do
b:=b*i;
writeln(Res=,b);
end.
Пример ввода:
3
Пример вывода:
6
Оцени ответ
