PYTHON. Даю 70 баллов. Решить с помощью циклов.
1) Найдите все пятизначные числа, которые при делении на 133 дают в остатке 125, а при делении на 134 дают в остатке 111.
2)Натуральное число называется числом Армстронга, если сумма цифр числа, возведенных в N-ную степень (где N – количество цифр в числе) равна самому числу. Например, 153 = 13 + 53 + 33. Найдите все трёхзначные Армстронга.
3)Натуральное число называется автоморфным, если оно равно последним цифрам своего квадрата. Например, 252 = 625. Напишите программу, которая получает натуральное число N и выводит на экран все автоморфные числа, не превосходящие N.

#задание 1
for i in range(10000,100000):
    if ((i % 133 == 125) & (i % 134 == 111)):
         print(i)

#задание 2
s=0
for i in range(100,1000):
    n=i
    while (n>0):
        s+=pow(n % 10,3)
        n=n // 10
    if (s==i):
        print(i)
    s=0

#задание 3
n=int(input(задайте N: ))
for i in range(1,n):
    d=10
    while (i>=d):
        d=d*10 
   if ((i*i % d)==i):
        print(число ,i,квадрат ,i*i) 
       

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку