1)дано целое число N(больше 0). Найти сумму 1+1/2+1/3.....1/N(вещественное число). Входные данные: ввести целое числоN(1<=n<=20)

Выходные данные: вывести сумму 1+1/2=1/3+.....1N с точностью до 4 цифр в дробной части.( в паскале)

var H: real;

   N, i: integer;

begin

   H := 0;

   readln(N);

   for i := 1 to N do

      H := H + 1/i;

   writeln(H:6:4)

end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку