тема: Цикл с предусловием. Задание :Ввести целое число и определить, верно ли, что в его записи есть две одинаковые цифры.
в паскале напишите программу плиз
Program A;
uses crt;
var
s: string;
k,j,f: integer;
ch: char;
begin
read(S);
f:=0;
for k:=1 to length(s) do
for j:=1 to length(s) do
if ((s[k]=s[j]) and (k<>j)) then begin f:=1; ch:=s[k]; end;
if f=1 then Writeln(YES - ,ch) else write(NO);
readln;
End.
Оцени ответ
